Minimum PHP version for running Magento Web Service APIs

Can anybody please suggest how to know the minimum PHP version, for working of the Magento v1.4.x.x Web Services?

My problem is that I am trying to run an API Web Service (having tried both V2 & normal SOAP) for downloading Store Lists. But nothing is returning, no error, no display nothing. I have also tried with run-time configurations (using in-built function “ini_set()“), but in vain:-

  • soap.wsdl_cache_enabled = 0
  • soap.wsdl_cache_ttl = 0
  • display_errors = 1

Thanks in advance.

One thought on “Minimum PHP version for running Magento Web Service APIs”

  1. The PHP version requirements listed on Magento’s site for PHP (5.2.13+) should be used for the latest releases. As far as the Web Services, as long as the PHP version requirements are met, and the SOAP module is installed and enabled you shouldn’t have any problems. For previous versions like 1.4.x.x, the last entry from way back machine shows 5.2.0+ So it would safe to assume the latest 5.2.x of PHP will work.

Leave a Reply

Your email address will not be published. Required fields are marked *