How do I create a Magento extension package that works in both 1.4 and 1.5?

I am having a hell of a time getting my extension up on Magento Connect. My first attempt I released as Beta, and on version 1.5 I was getting an error “Version number could not be found” when attempting to install. However, this package worked on Magento 1.4 (Magento Connect Manager version 1.0). So I repackaged, uploaded again – this time as Stable – and now the package works fine on Magento Connect 2.0 in Magento 1.5, but Magento Connect 1.0 can’t find the package and therefore can’t install it. All packages have been created in the Package Extensions tool of a Magento 1.5 install.

Also, is there a way to remove or overwrite uploaded extension packages or do I need to increment the version number with each upload?

One thought on “How do I create a Magento extension package that works in both 1.4 and 1.5?”

  1. The trick is to upload your package twice, first use the package output in /var/pear and then change the version, repackage and upload the one in /var/connect.

Leave a Reply

Your email address will not be published. Required fields are marked *