Could not add configurable product in Magent community version, shows fatal error?

I’m new to magento and learning things ..

First i installed the latest magento 1.5.1.0 and it throws too many error while configuring. As it a very new version and released recently, i installed magento 1.4.2.0

Its also often throwing some fatal errors , i dont know why its happening and almost all errors are related to products. One thing i try to add is a configurable product..

It throws Fatal error: Call to a member function getTable() on a non-object in /app/code/core/Mage/Core/Model/Mysql4/Collection/Abstract.php on line 454

Do anyone know how to rectify this? I tried to find answers in magento forum but failed.. 🙁

2 thoughts on “Could not add configurable product in Magent community version, shows fatal error?”

  1. I found the solution myself..

    There was a file name configurable.php inside

    appcodecoreMageCatalogModelResourceEavMysql4ProductType

    and it was wrongly named something like configurable.php0343235556 and i removed the unwanted numeric characters from the extension and it all worked after that… 🙂

    I already happened to found same naming problem in tierprice.php

    i dont know why magento have been releasing file with this weird filenames..!!!

    Hint on how i found the problem,

    i opened the file appvarlogsystem.log and removed all its contents and tried to create a configurable product and then viewed the same file and it has the error stating ‘warning :could not load file from … ‘

Leave a Reply

Your email address will not be published. Required fields are marked *